[pjsip] Error opening sound device: No suitable sound capture device

Cheng-Yen Lin kennylin30 at gmail.com
Thu Nov 8 03:53:23 EST 2007


Hi

I cross compiled pjsua for arm versatile platform with the arm AC97
sound device.  But it fail to initial sound device, the following is
the error message:

%
 00:07:57.497  pjsua_media.c RTP socket reachable at 140.114.71.69:4000
 00:07:57.497  pjsua_media.c RTCP socket reachable at 140.114.71.69:4001
 00:07:57.507  pjsua_media.c RTP socket reachable at 140.114.71.69:4002
 00:07:57.507  pjsua_media.c RTCP socket reachable at 140.114.71.69:4003
 00:07:57.516  pjsua_media.c RTP socket reachable at 140.114.71.69:4004
 00:07:57.516  pjsua_media.c RTCP socket reachable at 140.114.71.69:4005
 00:07:57.582  pjsua_media.c RTP socket reachable at 140.114.71.69:4006
 00:07:57.583  pjsua_media.c RTCP socket reachable at 140.114.71.69:4007
 00:07:57.583  pjsua_media.c pjsua_set_snd_dev(): attempting to open
devices @16000 Hz
 00:07:57.583  pjsua_media.c ..failed: No suitable sound capture
device (PJMEDIA_ENOSNDREC)
 00:07:57.584  pjsua_media.c pjsua_set_snd_dev(): attempting to open
devices @22050 Hz
 00:07:57.584  pjsua_media.c ..failed: No suitable sound capture
device (PJMEDIA_ENOSNDREC)
 00:07:57.584  pjsua_media.c pjsua_set_snd_dev(): attempting to open
devices @44100 Hz
 00:07:57.584  pjsua_media.c ..failed: No suitable sound capture
device (PJMEDIA_ENOSNDREC)
 00:07:57.584  pjsua_media.c pjsua_set_snd_dev(): attempting to open
devices @48000 Hz
 00:07:57.584  pjsua_media.c ..failed: No suitable sound capture
device (PJMEDIA_ENOSNDREC)
 00:07:57.584  pjsua_media.c pjsua_set_snd_dev(): attempting to open
devices @11025 Hz
 00:07:57.584  pjsua_media.c ..failed: No suitable sound capture
device (PJMEDIA_ENOSNDREC)
 00:07:57.584  pjsua_media.c pjsua_set_snd_dev(): attempting to open
devices @32000 Hz
 00:07:57.584  pjsua_media.c ..failed: No suitable sound capture
device (PJMEDIA_ENOSNDREC)
 00:07:57.584  pjsua_media.c pjsua_set_snd_dev(): attempting to open
devices @8000 Hz
 00:07:57.584  pjsua_media.c ..failed: No suitable sound capture
device (PJMEDIA_ENOSNDREC)
 00:07:57.584  pjsua_media.c Unable to open sound device: No suitable
sound capture device (PJMEDIA_ENOSNDREC) [status=220200]
 00:07:57.584  pjsua_media.c Error opening sound device: No suitable
sound capture device (PJMEDIA_ENOSNDREC) [status=220200]
 00:07:57.590   pjsua_core.c Shutting down...
 00:07:58.590  pjsua_media.c Closing (null) sound playback device and
(null) sound capture device
 00:07:58.980      pasound.c PortAudio sound library shutting down..
 00:07:58.981 sip_endpoint.c Module "mod-pjsua-options" unregistered
 00:07:58.981 sip_endpoint.c Module "mod-pjsua-im" unregistered
 00:07:58.981 sip_endpoint.c Module "mod-pjsua-pres" unregistered
%

then pjsua shutdown, if I start with --null-audio option then it works
ok. I can make sure that the sound device is ok , because i can
execute mad-palyer to play mp3. The following is some message with the
sound device.

dmesg
%
Advanced Linux Sound Architecture Driver Version 1.0.11rc4 (Wed Mar 22 10:27:24
2006 UTC).
aaci-pl041 fpga:04: ARM AC'97 Interface at 0x10004000, irq 24, fifo 512
atkbd.c: keyboard reset failed on fpga:06
atkbd.c: keyboard reset failed on fpga:07
ALSA device list:
  #0: ARM AC'97 Interface at 0x10004000, irq 24
%

ls -l /dev
%
/dev/audio      /dev/audio0     /dev/audio1     /dev/audioctl
/dev/dsp        /dev/dsp0       /dev/dsp1
%

any suggestion?? , thanks!!




More information about the pjsip mailing list