[pjsip] Build problem with version 7 on mingw (version 5 ok)

Benny Prijono bennylp at pjsip.org
Mon Sep 24 12:23:04 EDT 2007


Lafras Henning wrote:
> Hi Benny,
> 
> Ok, I found:
> 
> In version 5
> the make files in pjlib pjlib-util pjnath third_party pjmedia pjsip
> pjsip-apps all refer to
> .../../build/common.mak
> whereas in V7 some of them refer to $(PJDIR)/build/common.mak

Yup. The idea of PJDIR is to enable application to include build.mak 
in its Makefile and build application with ease.


> I think msys interprets  /home/Lafras/pj relative to its install location
> whereas c:/mingw/bin/make.exe does not.
> This may have to do with the msys/mingw install/setup procedure.

I suspect probably it's because of mount directories in Mingw. So 
"pwd" interprets the directory as /home, while make.exe uses the 
original directory location.


> The first solution affects all platforms but I don't know the effect is
> good.
> In aconfigure line 2747  change ac_pjdir=`pwd' to  ac_pjdir=`pwd -W`
> 
> Second option is to condition the change only to mingw as follows:
> case $target in *mingw* | *cygw* | *win32* | *w32* )
>  ac_pjdir=`pwd -W`
>  ;;
>   *)
>  ac_pjdir=`pwd`
>  ;;
> esac

That's a good solution, I've applied this in 
http://www.pjsip.org/trac/ticket/380. Thanks for spotting and fixing 
this!

cheers,
  -benny


> Third solution (if it is a msys/mingw install issue)
> in ./configure test that make.exe uses the correct path and warn user that
> mingw is not installed properly.
> 
> Regards
> Lafras






More information about the pjsip mailing list