[pjsip] message not received

Andreas Backman andreas.backman at sesca.com
Fri Apr 4 05:22:06 EDT 2008


Hi Benny!

Thanks for the tip! It works now!!

I've got F-secure firewall on this computer. I changed the trusted
network adapter from "none" to the one that I'm using and it worked like
a charm.
This is maybe not the safest way of doing it so I tried to apply a rule
and also add a so called "service" in F-secure's lists but without any
difference than before.
So instead I activated the "application control" and got those
irritating popups, saying a program wants to access internet. I accepted
it for my SIP UAs, and it worked again.


Another question about the same topic:
Is it possible to activate the keep-alive routine for UDP without STUN
enabled?


Br,
Andreas


-----Original Message-----
From: pjsip-bounces at lists.pjsip.org
[mailto:pjsip-bounces at lists.pjsip.org] On Behalf Of Benny Prijono
Sent: 3. huhtikuuta 2008 17:33
To: pjsip list
Subject: Re: [pjsip] message not received

On Thu, Apr 3, 2008 at 12:36 PM, Andreas Backman
<andreas.backman at sesca.com> wrote:
> Hi!
>
> I have noticed a strange behavior with PJSIP/PJSUA.
>
> It appears as follows:
>
> Everything works fine with registration to server and status
publishing. I
> can also send and receive IMs (tested with several different SIP UAs)
> without a problem.
>
> But if I leave the PJSUA unused (not sending IMs to or from it) for a
short
> period of time (like a minute or two) it just won't receive any more
> messages. The other UA just keeps sending the same IMs until a 408
Request
> Timeout occurs.
>

That sounds like a typical NAT problem. Strange as it might sound,
I've sometimes got the same problem, not with SIP though but with our
TURN client. After 1-3 minutes idle the data sent by TURN server
(located on the same LAN!) can't reach the client, and it will only
get through again after client sends outgoing data to to TURN server.
Wireshark says data does arrive in client, but still the client
application doesn't read it.

I also tried that on a WinXP SP2. And this problem goes away once I
turn off my Windows firewall. Could you try that?

Cheers
 Benny


>
> I tried to track down the problem by setting a higher log level and
found
> that after some transactions where destroyed (see last section in the
log
> attached) PJSUA stopped responding to incoming IMs. If I at that state
send
> an IM or update presence from PJSUA, messages from other UAs can be
received
> again. Sometimes it can continue as normal after some longer time of
> waiting, but that can due to re-register or re-publish.
>
>
>
> It looks like some thread is being stucked at some point and is unable
to
> continue until something is sent from PJSIP.
>
> The problem is the same using PJSUA or my own program based on
pjsua-lib.
> Using the latest trunk (rev 1906) or 0.8.0 doesn't change anything.
>
> I'm running Windows XP SP2 and using Visual Studio 2005 to compile the
> source (compiled with an empty config_site.h). The program is started
with
> the following parameters:
>
> --id=sip:testperson at 192.168.0.10 --registrar=sip:192.168.0.10
--realm=*
> --username=testperson --password=passwd --publish --local-port=5070
--no-tcp
> --null-audio --app-log-level=6
>
> Twinkle on linux is used as the other UA in this case, but as
mentioned
> earlier it's the same thing with others such as OpenWengo or X-lite.
>
>
>
> Any one else seen something like this??
>
>
>
> Help is really appreciated
>
>
>
> Br,
>
> Andreas
> _______________________________________________
>  Visit our blog: http://blog.pjsip.org
>
>  pjsip mailing list
>  pjsip at lists.pjsip.org
>  http://lists.pjsip.org/mailman/listinfo/pjsip_lists.pjsip.org
>
>

_______________________________________________
Visit our blog: http://blog.pjsip.org

pjsip mailing list
pjsip at lists.pjsip.org
http://lists.pjsip.org/mailman/listinfo/pjsip_lists.pjsip.org




More information about the pjsip mailing list