[pjsip] message not received

Benny Prijono bennylp at pjsip.org
Fri Apr 4 07:07:03 EDT 2008


On Fri, Apr 4, 2008 at 10:22 AM, Andreas Backman
<andreas.backman at sesca.com> wrote:
> Hi Benny!
>
>  Thanks for the tip! It works now!!
>
>  I've got F-secure firewall on this computer. I changed the trusted
>  network adapter from "none" to the one that I'm using and it worked like
>  a charm.
>  This is maybe not the safest way of doing it so I tried to apply a rule
>  and also add a so called "service" in F-secure's lists but without any
>  difference than before.
>  So instead I activated the "application control" and got those
>  irritating popups, saying a program wants to access internet. I accepted
>  it for my SIP UAs, and it worked again.
>

Okay. I also just realized that my application was not listed in
"allowed" list in the Windows Firewall config. And strangely it didn't
show up the popup when I started it again. Maybe I accidently pressed
the wrong button then. Adding the app to the "allowed" list also fixed
my problem.

So it looks like when an application is not marked as "allowed",
Windows will only forward incoming packet to the application only when
the application has recently sent outgoing packet using the socket.
Interesting, as I thought Windows will refuse to send/receive packets
altogether.

>  Another question about the same topic:
>  Is it possible to activate the keep-alive routine for UDP without STUN
>  enabled?
>

Just did, in http://trac.pjsip.org/repos/ticket/522

Thanks
 Benny


>  Br,
>  Andreas
>




More information about the pjsip mailing list