[pjsip] Debugging silent TLS failure in current SVN build

Benny Prijono bennylp at pjsip.org
Mon Apr 7 17:24:36 EDT 2008


On Mon, Apr 7, 2008 at 4:53 PM, Michael CHRISTOPHER <pjsip at encambio.com> wrote:
>  Hello list,
>
>  When running a successful build of pjsua, sometimes nothing happens.
>  For example, on Linux/ARM (and maybe others) the current SVN build
>  fails when using TLS. No text is printed to the console or to any
>  log file, regardless of how the --log-file, --log-level, and
>  --app-log-level are set. The pjsua process ends almost immediately.
>
>  What is the best practice of debugging such failures, and if
>  somebody has a clue as to why the current SVN build is failing
>  in this way, please help out. This was working a couple weeks ago.

Are you still building with PJ_CONFIG_MINIMAL_SIZE? If yes, then
don't! With PJ_CONFIG_MINIMAL_SIZE, logging is disabled, and if
anything goes wrong then basically we've nothing. So try with using an
empty config_site.h first, and do optimization later when everything
has been running fine. The default values normally should be good
enough for most uses.

Cheers
 Benny


>   $ ltrace /usr/bin/pjsua --null-audio --use-tls
>   [...]
>   strncmp("use-tls", "use-tls", 7)                 = 0
>   strlen("use-tls")                                = 7
>   strlen("use-tls")                                = 7
>   +++ exited (status 1) +++
>   $
>
>   $ strace /usr/bin/pjsua --null-audio --use-tls
>   [...]
>   gettimeofday({1207583220, 976308}, NULL) = 0
>   poll([{fd=3, events=POLLOUT, revents=POLLOUT}], 1, 0) = 1
>   send(3, "B\335\1\0\0\1\0\0\0\0\0\0\fvmscratmaemo\teuropa"..., 44, MSG_NOSIGNAL) = 44
>   poll([{fd=3, events=POLLIN, revents=POLLIN}], 1, 5000) = 1
>   ioctl(3, FIONREAD, [333])               = 0
>   recvfrom(3,
>   "B\335\205\200\0\1\0\1\0\n\0\2\fmaemohost\tdomain"..., 1024, 0, {sa_family=AF_INET, sin_port=htons(53), sin_addr=inet_addr("***.***.***.***")}, [16]) = 333
>   close(3)                                = 0
>   gettimeofday({1207583220, 991479}, NULL) = 0
>   futex(0x815f4c8, FUTEX_WAKE, 1)         = 0
>   exit_group(1)                           = ?
>   Process 18075 detached
>   $
>
>  Regards,
>  Michael
>
>  _______________________________________________
>  Visit our blog: http://blog.pjsip.org
>
>  pjsip mailing list
>  pjsip at lists.pjsip.org
>  http://lists.pjsip.org/mailman/listinfo/pjsip_lists.pjsip.org
>




More information about the pjsip mailing list