[pjsip] Bad Request Line --- REGISTER sip:pcscf.open-ims.net:4060

Benny Prijono bennylp at pjsip.org
Sun Apr 20 08:14:10 EDT 2008


On Sat, Apr 19, 2008 at 11:00 PM, Adeyeye Michael
<micadeyeye at crg.ee.uct.ac.za> wrote:
> Hi Benny,
>  Sorry for the multiple post. I used our client, UCTIMSCLIENT and I could
>  register with the core. I have tried appending ";lr" to --proxy value
>  but no authorization header is sent. I only see Authorization header
>  when I remove ";lr" yet it doesn't register with the IMS Core.
>
>  I have no inkling of what could be wrong.
>  I have been using this:
>
>  micadeyeye at micadeyeye-desktop:/opt/pjproject-0.8.0/pjsip-apps/bin$
>   ./pjsua-i686-pc-linux-gnu --registrar sip:open-ims.test --id  sip:bob at open-ims.test --username bob at open-ims.test --password bob
>
> --local-port 5066 --realm open-ims.test --proxy sip:pcscf.open-ims.test:4060;lr --use-ims
>

I just tried with using your config above (changed the Route to
localhost, otherwise it won't  resolve) and my REGISTER request did
have an empty Authorization header:


REGISTER sip:open-ims.test SIP/2.0
Via: SIP/2.0/UDP 12.184.85.49:5066;rport;branch=z9hG4bKPj4e867964051e4604bcf39d9
a5ac4e284
Route: <sip:localhost:4060;lr>
Max-Forwards: 70
From: <sip:bob at open-ims.test>;tag=cc602cb43f8e415fb653b45e882082f0
To: <sip:bob at open-ims.test>
Call-ID: cd8a1f3a037c4cefa9b8f8af070fc859
CSeq: 40049 REGISTER
Authorization: Digest username="bob at open-ims.test", realm="open-ims.test", nonce
="", uri="sip:open-ims.test", response=""
User-Agent: PJSUA v0.8.0-trunk/win32
Contact: <sip:bob at 12.184.85.49:5066>
Expires: 300
Content-Length:  0


And these are what I have in my config_site.h:

#define PJSIP_HAS_TLS_TRANSPORT     1
#define PJSIP_HAS_DIGEST_AKA_AUTH   1
#define PJ_LOG_MAX_SIZE             4000
#define PJSIP_MAX_PKT_LEN           4000
#define PJ_HAS_IPV6                 1

I think the only line that matters is PJSIP_HAS_DIGEST_AKA_AUTH, but I
thought I show them all just in case.

And I'm using the latest version from the SVN.

Cheers
 Benny




More information about the pjsip mailing list