[pjsip] Missing RTP packets

Jack Bonn jack.bonn at swlabs.com
Wed Apr 30 15:38:26 EDT 2008


I retrieved the latest from the Subversion database and have built an
image that almost works in the CE 5.0 environment.  I am testing against
SJphone running on the PC.  As I previously mentioned, I had to change the
definition of VSNPRINTF in pa_debugprint.c to get things to compile, and
changed a few things in pjsua_wince.cpp: the value of SIP_DST_URI,
disabled STUN and disabled ICE.  I am testing on a local network, so STUN
and ICE would seem to be unnecessary.

I can establish connection in either direction, either from SJphone to
wince_demos or visa versa.

The audio from the PC to the WinCE computer seems fine.  Clear and very
little delay; much less delay than with Microsoft's CE VOIP demo (which
seemed excessive).

Here is the problem: the audio from the CE box toward the PC is choppy and
eventually drops down to a few clicks.  At this point, few RTP packets are
being sent toward the PC (as indicated by WireShark).  Those few remaining
packets being sent by wince_demos all have the "Mark" bit set.

I have my options in config_site.h set as follows:

   # define PJ_HAS_FLOATING_POINT 1
   # define PJMEDIA_HAS_G722_CODEC 0
   # define PJMEDIA_HAS_G711_PLC 0
   # define PJMEDIA_HAS_L16_CODEC 0
   # define PJMEDIA_HAS_GSM_CODEC 1
   # define PJMEDIA_HAS_ILBC_CODEC 0
   # define PJMEDIA_HAS_SPEEX_CODEC 0
   # define PJMEDIA_HAS_SPEEX_AEC 0
   # undef PJMEDIA_RESAMPLE_IMP
   # define PJMEDIA_RESAMPLE_IMP PJMEDIA_RESAMPLE_LIBRESAMPLE
   # define PJMEDIA_WSOLA_IMP PJMEDIA_WSOLA_IMP_NULL
   # define PJMEDIA_HAS_SRTP 0

WireShark indicates that GSM codecs are used in both directions.

Not sure where to look next.  Suggestions?

-- 
Jack Bonn  <> Software Design Labs, Inc.
jack.bonn at swlabs.com (847)526-1337

Dyslexics untie.





More information about the pjsip mailing list