[pjsip] segfault with 180 Ringing

Benny Prijono bennylp at pjsip.org
Sat Aug 2 06:29:54 EDT 2008


On Sat, Aug 2, 2008 at 7:54 AM, Ondrej Sterbak <sterbo at email.cz> wrote:

> Hey Benny!
>
> So 2 pjsua clients from the latest SVN trunk registering and calling
> through OpenSER 1.3.1-notls. Their config is same:
> --id=sip:tcp-user at example.com <sip%3Atcp-user at example.com>;transport=TCP
> --registrar=sip:example.com:50605;transport=TCP
> --max-calls=1
> --auto-answer=180
>
>
Does it happen only when you're registering with the same user id?
And did you have a third pjsua to call this id, or one of them call the
other?


> As I've said before, if I send 200 directly after 100 then it works
> fine. Just 180 which has before changed call state to EARLY makes it
> segfault.
>
> During writing of this email I realised it doesn't need to be
> connected to TCP and it is not! The same happens with UDP now as well.
> It used to work about 30 revisions back with UDP but it segfaults now.
> You should be able to reproduce this easily.
>
>
Actually I can't reproduce it here at all. Using the latest SVN, on both
Linux and Windows, tried the same config (with different user), through
OpenSER too, although I have  OpenSER 1.3.2-tls, call each other, or use
another pjsua to call them, and it worked as expected.

Can you send the complete log files perhaps? Or better if you could compile
pjsua with debug flag (add "export CFLAGS+=-g" in your user.mak and rebuild)
and run them under gdb and see if you could make sense of what's happening.

Cheers
 Benny



> Cheers,
> Ondrej
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.pjsip.org/pipermail/pjsip_lists.pjsip.org/attachments/20080802/ade12e03/attachment-0001.html 


More information about the pjsip mailing list