[pjsip] Problems facing in emulator

ssanz u ssanz.u1 at gmail.com
Mon Feb 4 04:56:19 EST 2008


Hi,
I am trying to execute PJSIP application in symbian s60 emulator with
carbide c++.
I installed asterisk server and it is running in one machine and the IP is
192.168.64.106 and the port is 5060.
My PJSIP application is installed in another machine (IP : 192.168.64.112)and
the parameters which i given in the ua.cpp file is,

SIP_PORT  5060
SIP_DST_URI  "sip:192.168.64.106:5060" #define HAS_SIP_ACCOUNT 1
#define SIP_DOMAIN "192.168.64.112"
#define SIP_USER ""
#define SIP_PASSWD ""
#define SIP_PROXY "sip:192.168.64.106"
#define NAMESERVER NULL

# define STUN_DOMAIN    NULL
# define STUN_SERVER    "stun.fwdnet.net"

#   define STUN_DOMAIN "xten.com"
#   define STUN_SERVER "stun.xten.com"

#   define STUN_DOMAIN NULL
#   define STUN_SERVER NULL
Emulator is shutting down immediately. I am not able to proceed further.
I got the following errors in the emulator.*"Error contacting STUN server "
: Received no response from STUN server (PJLIB_UTIL_ESTUNNORESPOND)*
*"Error creating transport"  : Received no response from STUN server
(PJLIB_UTIL_ESTUNNORESPOND)*

what parameters should i give in the STUN_DOMAIN & STUN_SERVER. Please help
me.



Thanks in advance,

sans
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pjsip.org/pipermail/pjsip_lists.pjsip.org/attachments/20080204/36660a05/attachment.html>


More information about the pjsip mailing list