[pjsip] Calling Xlite Counterpath

Benny Prijono bennylp at pjsip.org
Sat Feb 9 07:40:56 EST 2008


This problem sounds similar to
http://www.pjsip.org/pipermail/pjsip/2007-January/001773.html

Try upgrading Xlite and see if it helps.

cheers,
 -benny

On 2/8/08, P.J. Cast. <pjcast at yahoo.com> wrote:
> Using a fairly recent SVN version of pjsip, (it has
> been like since first version I tried in December)
> calling an Xlite phone does not work. I could provide
> a SIP Packet Capture if it might help... But, the
> issue seems so easy to reproduce that I think that is
> not needed.
>
> Basically, when calling from pjsip client (pjsua demo)
> to Xlite phone, it gets the INVITE message, and sends
> 200 OK - but with no media. Hence, there is a
> connected call, but for whatever reason, media
> negotiation broke. Happens always... which is why I
> wonder why no one else has mentioned this?
>
> It seems to me that something pjsip is sending is
> breaking xlite's ability to chose a codec (I tried
> enable all codecs and enabling just PCMU). However,
> when Xlite calls pjsip client, everything works as
> expected.
>
> I think Xlite is broken in someway, as the pjsip
> client (so far) has been able to place calls to any
> other SIP device. But, Xlite seems like it is fairly
> widely used, so I hope that the issue is a simple fix.
> It is possible that the issue is somehow caused from
> the SIP Proxy I am using to call through, but since
> everything else but Xlite phone is working great, I
> don't really see how.
>
> Thanks,
> Phil




More information about the pjsip mailing list