[pjsip] Callbacks still called back after pjmedia_port_destroy

Norman Franke norman at myasd.com
Mon Feb 11 17:54:57 EST 2008


I don't get a crash, but it could be one in the same. I'm definitely  
getting a call back after it was destroyed. Sounds like the main  
thread should just mark it as closed and clean it up some other way.  
Or perhaps destroy can remove the port (so it won't get call backs),  
unlock, then re-lock and destroy?

Norman Franke
Answering Service for Directors, Inc.
www.myasd.com

On Feb 9, 2008, at 7:36 AM, Benny Prijono wrote:

> On 2/8/08, Norman Franke <Norman at myasd.com> wrote:
>>  I've had a few crashes in get_frame after calling  
>> pjmedia_port_destroy in
>> another thread. (And pjmedia_port_destroy completed OK.) This  
>> seems rather
>> bad. Is this really possible? And if so, can it be fixed?
>
> This probably is the same problem as "Question about stream.c" post
> here: http://lists.pjsip.org/pipermail/pjsip_lists.pjsip.org/2008- 
> January/001463.html
>
> The bad news is, we don't have solution for this yet.
>
> cheers,
>  -benny
>
> _______________________________________________
> Visit our blog: http://blog.pjsip.org
>
> pjsip mailing list
> pjsip at lists.pjsip.org
> http://lists.pjsip.org/mailman/listinfo/pjsip_lists.pjsip.org

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pjsip.org/pipermail/pjsip_lists.pjsip.org/attachments/20080211/802fd714/attachment.html>


More information about the pjsip mailing list