[pjsip] UMTS Troubleshooting

Angelos Karageorgiou angelos at unix.gr
Tue Feb 12 06:50:34 EST 2008


Did you try STUN ? it is for these weird cases


Tzury Bar Yochay wrote:
> Hi,
>
> I got my pjsua_wince working great over WiFi.
>
> However, when switching to UMTS and try to connect to asterisk under 
> the following layout:
>
> Asterisk on 10.0.0.205 <http://10.0.0.205>
> Workstation on 10.0.0.200 <http://10.0.0.200> with sjphone (ext. 200)
>
> Both behind a router with certain public IP.
>
> HTC device with pjsua_wince installed (ext. 205) and configured 
> properly to use the public IP and to call the extension.
>
> I also set DMZ on the router to eliminate NAT Issues.
>
> I observe the following symptom:
>
> Pressing call button on pjsua_wince makes the SoftPhone on the 
> workstation to ring but pressing answer on the softphone don't cause a 
> start of call.
>
> By running wireshark I can see that there is a query from the router 
> IP which reads "Who has 10.220.y.z" which I assume is the private IP 
> that the HTC got from the GSM provider and since 10.220.y.z is not a 
> "legal" IP it search inside the lan which ofcourse has no such address.
>
> In short,  I suspect that the GSM provider provide the internal IP 
> instead of the public one which preven the ACK from reaching the 
> end-point.
>
> This might be beyond the scope of pjsip but I wonder if anybody have 
> struggled with this ip-translation issue.
>
> Thanks in advance
> Tzury
>
>
>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: angelos.vcf
Type: text/x-vcard
Size: 347 bytes
Desc: not available
URL: <http://lists.pjsip.org/pipermail/pjsip_lists.pjsip.org/attachments/20080212/abba88ca/attachment.vcf>


More information about the pjsip mailing list