[pjsip] symbian fails over an E65

Rodrigo Vega vegaroy13 at gmail.com
Tue Feb 12 17:23:13 EST 2008


Hi benny:

First of all I want to thank you for all your support.

Finaly I can make calls from pjsua_wince over an ipaq hp. It was problems of
installations, but solved successfully.

Now I'm working over a phone Nokia E65 which it's compatible with the
Building and Debugging PJSIP on Symbian S60 3rd Edition Device using Carbide
C++ tutorial.

Compilations works.
Sending the application to the phone works.
It runs.

I'm doing a call from the ipaq hp to the symbian phone.

Asterisk says this:

[Feb 12 15:56:49] NOTICE[10306]: chan_sip.c:12517 handle_response_peerpoke:
Peer 'symbian' is now Reachable. (1211ms / 2000ms)
[Feb 12 15:56:52] NOTICE[10306]: chan_sip.c:12517 handle_response_peerpoke:
Peer 'wincewm' is now Reachable. (1024ms / 2000ms)
    -- Executing [711 at internal:1] Dial("SIP/wincewm-081ed998",
"SIP/symbian") in new stack
    -- Called symbian
    -- SIP/symbian-081f78d0 is ringing
    -- SIP/symbian-081f78d0 answered SIP/wincewm-081ed998
    -- Packet2Packet bridging SIP/wincewm-081ed998 and SIP/symbian-081f78d0
[Feb 12 15:57:53] NOTICE[10306]: chan_sip.c:15655 sip_poke_noanswer: Peer
'symbian' is now UNREACHABLE!  Last qualify: 1211

I press the button 1 on the symbian phone (like pressing buttom 'a' of
answere).

I cannot read every thins that the console prints on the phone, I can see
something about RTP... finaly shows up this text:

assertion "!" Unsupported address family"" failed: file
"..\\pjlib\\src\\/os_symbian.h", line 295

and then ask to press any key, and the application dies.

My macro's config are these ones:

//
// Basic config.
//
#define SIP_PORT    5060


//
// Destination URI (to make call, or to subscribe presence)
//
#define SIP_DST_URI    "sip:echo at 192.168.1.73"

//
// Account
//
#define HAS_SIP_ACCOUNT    1    // 0 to disable registration
#define SIP_DOMAIN    "192.168.1.73"
#define SIP_USER    "symbian"
#define SIP_PASSWD    "symb"

//
// Outbound proxy for all accounts
//
#define SIP_PROXY    NULL
#define SIP_PROXY    "sip:192.168.1.73:lr"


//
// Configure nameserver if DNS SRV is to be used with both SIP
// or STUN (for STUN see other settings below)
//
#define NAMESERVER    NULL
//#define NAMESERVER    "192.168.0.1"

//
// STUN server
#if 0
    // Use this to have the STUN server resolved normally
#   define STUN_DOMAIN    NULL
#   define STUN_SERVER    "stun.xten.com"
#elif 0
    // Use this to have the STUN server resolved with DNS SRV
#   define STUN_DOMAIN    "iptel.org"
#   define STUN_SERVER    NULL
#else
    // Use this to disable STUN
#   define STUN_DOMAIN    NULL
#   define STUN_SERVER    NULL
#endif

//
// Use ICE?
//
#define USE_ICE        1



I also had another problem which was solved doing this:

cfg.cred_info[0].realm = pj_str("*");//pj_str(SIP_DOMAIN);

because for asterisk could be "asterisk" or "*" that is the wild-card.


Which is the problem here?

Thanks for your support.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pjsip.org/pipermail/pjsip_lists.pjsip.org/attachments/20080212/05299c20/attachment.html>


More information about the pjsip mailing list