[pjsip] Unable to make call on same host with revision 1824

Benny Prijono bennylp at pjsip.org
Thu Feb 28 10:36:41 EST 2008


On 2/28/08, Dan <dan.aberg at keystream.se> wrote:
> Hi,
>  I just checked out the latest revision(1824), and now I'm not able to
>  make a call between two instances running on the sam host.
>
>  Instance 1:
>  ./pjsua-i686-pc-linux-gnu --local-port=6028 --no-vad --ec-tail=0
>  --auto-answer=200
>
>  Instance 2:
>  ./pjsua-i686-pc-linux-gnu --auto-loop --no-vad --ec-tail=0
>  --auto-answer=200 --null-audio
>
>  When I make a call from instance 1 to sip:127.0.0.1, instance 2 freezes
>  after receiving the initial INVITE.
>
>  The last time I tried this was with revision 1786, which worked just
>  fine.

Hi Dan,

>From the log (off list), it seems that the call was rejected with 484
Address Incomplete, because the request was like this:

INVITE sip:domain SIP/2.0
Route: <sip:400 at domain>

So you're using strict route, and it seems that your OpenSER couldn't
handle this (maybe a configuration problem?).

This worked in r1786, because we had this bug:
http://trac.pjsip.org/repos/ticket/492, which incorrectly swapped back
the Route with the request URI after the request is challenged with
401/407.

So the solution is to use loose route, by adding ";lr" in your route URI.

cheers,
 -benny


>  Thanks,
>  Dan
>
>
>
>  _______________________________________________
>  Visit our blog: http://blog.pjsip.org
>
>  pjsip mailing list
>  pjsip at lists.pjsip.org
>  http://lists.pjsip.org/mailman/listinfo/pjsip_lists.pjsip.org
>




More information about the pjsip mailing list