[pjsip] Missing Separator Error

Samer Faour smf18 at aub.edu.lb
Fri May 2 17:31:30 EDT 2008


According to the FAQ:

"
One user reported this compile error, something like:

      
"\Symbian\9.1\S60_3rd_MR\EPOC32\BUILD\project\pjproject\build.symbian\PJLIB\GCCE\PJLIB.GCCE *** missing separator.  
Stop."

This problem may be similar to this problem reported on Nokia Forum.  
See if adding ARM toolchain to the PATH (C:\Program Files\CSL Arm  
Toolchain\bin) solves it.

If not, please check that you have the correct Perl version for the  
SDK. Try reinstalling everything (Perl, ARM toolchain, and SDK) and  
see if it helps.
"

That user was ME :)

Now I wanted to try the Symbian build again and encountered that  
all-too-familiar error. So I uninstalled everything and cleaned the  
registry (using CCleaner) and then reinstalled everything, and added  
the ARM toolchain to the PATH and I still can't escape this error.

So just to be sure, I also performed a clean install of ARM,  
ActivePerl, SDKs, and Carbide C++ 1.2 on a computer than never had any  
of these programs installed on it (hence the term 'clean' install).  
Fixed PATH. Same result.

I tried manually including the directory in the include directories of  
the project. This also made no difference. As before, this error is  
very specific. The error pertains to line 75 in PJLIB.GCCE:

..\lib\gcc\arm-none-symbianelf\3.4.3\include"

OH and one more thing. Running all this from the command line tools  
using 00.bat and 01.bat gives the same result. 00.bat does the bldmake  
or whatever and 01.bat stops right after the error. I'm really out of  
ideas. Any help would be appreciated.

Thanks.
________________________________________
Samer M. Faour
Computer and Communications Engineering
American University of Beirut
P.O. Box 11-0236/ 1461
Riad el Solh Square 1107 - 2020
Email: smf18 at aub.edu.lb





----------------------------------------------------------------





More information about the pjsip mailing list