[pjsip] PJSIP & LAN

Alan J. Bond alan.bond at wintology.com
Fri May 9 05:45:00 EDT 2008


Ayman,

Still waiting for that picture - with IP addresses, masks and who's serving who with DHCP, etc. :-).

If I remember correctly (and it's been a long time, I'm really not your man here) the WinCE emulator by default operates a virtual network inside your PC on a different subnet and serves up the emulated device with an IP address in this range.  It also has a virtual HTTP proxy with one foot in this virtual network and the other on your PC's real IP address.  This allows you to browse from the browser in the emulated device to the outside world but is no use to VoIP at all.  That is probably why you can see HTTP related stuff in WireShark but not SIP traffic on port 5060, etc.

Have a look at this thread in the archive, which sounds very similar to what you're saying ...

http://lists.pjsip.org/pipermail/pjsip_lists.pjsip.org/2008-February/thread.html#1564

Read through all the posts in this thread and make sure you have all the bases covered, there's a lot of detail here.
Alan.

From: pjsip-bounces at lists.pjsip.org [mailto:pjsip-bounces at lists.pjsip.org] On Behalf Of Ayman Farouk
Sent: 09 May 2008 09:50
To: pjsip at lists.pjsip.org
Subject: [pjsip] PJSIP & LAN

I just wanted to add something.. the emulator and the device take an IP address with different subnet mask I guess.. my server is 192.168.1.112<http://192.168.1.112> while the device and the emulator keep taking ( 192.254.2.1<http://192.254.2.1>)  Would this be a problem? or the problem ?

Thanks,
--
a.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pjsip.org/pipermail/pjsip_lists.pjsip.org/attachments/20080509/b171a1e9/attachment.html>


More information about the pjsip mailing list