[pjsip] Play audio with samples/playfile correctly, but not on pjsua

Fan-Cheng Wu 吳梵誠 fcwu.tw at gmail.com
Sun May 11 03:22:38 EDT 2008


(This is the same content with previous message I posted. I didn't see the
message on http://news.gmane.org/gmane.comp.voip.pjsip, so I post it again)
Hi all,

I tried to play a wav file with
pjsip-apps/bin/samples/playfile-arm-unknown-none, and I can hear the audio
correctly. But when I run bin/pjsua-arm-unknown-none and play a wav file in
program(http://trac.pjsip.org/repos/wiki/audio-check-play), the audio would
be heard like someone's screak.

How can I fix the problem? My platform is MontaVista 4.0 with ARM 9. (ps.
the same condition happened when I compilied it for Ubuntu 8.04 with x86)

Thanks a lot.

Here are some log when I run two program:
root at 192.168.127.100:~/pjproject-0.8.0_arm/pjsip-apps#
bin/samples/playfile-arm-unknown-none ~/ring.wav
 17:54:20.894 os_core_unix.c pjlib 0.8.0 for POSIX initialized
 17:54:21.508      pasound.c PortAudio sound library initialized, status=0
 17:54:21.509      pasound.c PortAudio host api count=2
 17:54:21.510      pasound.c Sound device count=1
 17:54:21.521          pjlib select() I/O Queue created (0x82f34)
 17:54:21.529   wav_player.c File player '/root/ring.wav' created:
samp.rate=11025, ch=1, bufsize=4KB, filesize=31KB
 17:54:21.670      pasound.c Opened device 0: /dev/dsp(OSS) for playing,
sample rate=11025, ch=1, bits=16, 220 samples per frame, latency=23 ms
 17:54:21.671      pasound.c Starting /dev/dsp stream..
 17:54:21.687      pasound.c Player thread started
 17:54:21.688      pasound.c Done, status=0

root at 192.168.127.100:~/pjproject-0.8.0_arm/pjsip-apps#
bin/pjsua-arm-unknown-none --play-file ~/ring.wav --log-level=6
--playback-dev=0 --capture-dev=0 --app-log-level 5
......
 17:54:54.642   wav_player.c File player '/root/ring.wav' created:
samp.rate=11025, ch=1, bufsize=4KB, filesize=31KB
 17:54:54.643     resample.c resample created: high qualiy, large filter,
in/out rate=11025/16000
 17:54:54.644     resample.c resample created: high qualiy, large filter,
in/out rate=16000/11025
.......
 17:54:54.812      pasound.c Opened device /dev/dsp(OSS)//dev/dsp(OSS) for
recording and playback, sample rate=16000, ch=1, bits=16, 160 samples per
frame, input latency=16 ms, output latency=16 ms
 17:54:54.814      pasound.c Starting /dev/dsp stream..
 17:54:54.825      pasound.c Recorder thread started
 17:54:54.826 os_core_unix.c Info: possibly re-registering existing thread
 17:54:54.826      pasound.c Player thread started
 17:54:54.828      pasound.c Done, status=0
 17:54:54.926   echo_speex.c Speex Echo canceller/AEC created,
clock_rate=16000, samples per frame=160, tail length=200 ms, latency=32 ms
........
 17:54:56.104   pjsua_core.c Shutting down...
 17:54:58.003  pjsua_media.c Closing /dev/dsp sound playback device and
/dev/dsp sound capture device
 17:55:00.023      pasound.c Stopping stream..
 17:55:00.023      pasound.c Done, status=0
 17:55:02.023      pasound.c Closing /dev/dsp: 0 underflow, 0 overflow
 17:55:02.143      pasound.c PortAudio sound library shutting down..
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pjsip.org/pipermail/pjsip_lists.pjsip.org/attachments/20080511/87a2daa3/attachment.html>


More information about the pjsip mailing list