[pjsip] Error in configuring SVN version, on Linux, i686

Benny Prijono bennylp at pjsip.org
Tue May 13 13:27:00 EDT 2008


Actually when I run ./config.status, it creates a temporary directory
under current directory, here it's called "confstat1244-27231" (the
number is random is presume so it'll be different on your computer).
Under this directory there are several .sed files.

Can you show me the contents of undefs.sed?

And do you see a correct os_auto.h content when you run this?

  sed -f confstat1244-27231/undefs.sed pjlib/include/pj/compat/os_auto.h.in

Cheers
 Benny

On Tue, May 13, 2008 at 4:31 PM, Tanguy Floc'h <electrocut at gmail.com> wrote:
> Thank you very much for your quick answer.
>
> I have try to delete pjlib/include/pj/compat/os_auto.h,
> then re-run ./config.status
>
> The file os_auto.h has been re-created, but it's content is still the same
> (only #undef items).
>  You can have a look at the file at the adress :
> http://docs.google.com/View?docid=dcmdgqxp_24xrqcjgc&hl=en
>
> and this is the ./config.status result :
>
> [tflo at D820-15 Stack_PjSIP]$ ./config.status
>
> config.status: creating build.mak
> config.status: creating build/os-auto.mak
> config.status: creating pjlib/build/os-auto.mak
> config.status: creating pjlib-util/build/os-auto.mak
>  config.status: creating pjmedia/build/os-auto.mak
> config.status: creating pjsip/build/os-auto.mak
> config.status: creating third_party/build/portaudio/os-auto.mak
> config.status: creating third_party/build/os-auto.mak
>  config.status: creating pjlib/include/pj/compat/os_auto.h
> config.status: creating pjlib/include/pj/compat/m_auto.h
> config.status: pjlib/include/pj/compat/m_auto.h is unchanged
> config.status: creating pjmedia/include/pjmedia/config_auto.h
>  config.status: pjmedia/include/pjmedia/config_auto.h is unchanged
> config.status: creating pjmedia/include/pjmedia-codec/config_auto.h
> config.status: pjmedia/include/pjmedia-codec/config_auto.h is unchanged
> config.status: creating pjsip/include/pjsip/sip_autoconf.h
>  config.status: pjsip/include/pjsip/sip_autoconf.h is unchanged
>
> tail -100 config.log has not changed either
>
> Electrocut
>
>
>
> On Tue, May 13, 2008 at 4:48 PM, Benny Prijono <bennylp at pjsip.org> wrote:
>
> >
> > On Tue, May 13, 2008 at 2:35 PM, Tanguy Floc'h <electrocut at gmail.com>
> wrote:
> > > Hi ! Now I'm trying to use last pjsip trunk under Linux (CentOs 5
> distrib)
> > >
> > > I think I've almost the same building problem as described in the post :
> > >
> http://lists.pjsip.org/pipermail/pjsip_lists.pjsip.org/2008-January/001452.html
> > > (the problem has no been solved, since the person hasn't reply to your
> > > questions)
> > >
> > > See ./configure log below :
> > >
> > > [tflo at D820-15 Stack_PjSIP]$ ./configure
> > > checking build system type... i686-pc-linux-gnu
> > > checking host system type... i686-pc-linux-gnu
> > > checking target system type... i686-pc-linux-gnu
> > >  checking for gcc... gcc
> >
> > [snip. Everything looks proper there..]
> >
> >
> > > config.status: creating pjlib/include/pj/compat/os_auto.h
> > > config.status: pjlib/include/pj/compat/os_auto.h is unchanged
> >
> > Okay this says that os_auto.h is unchanged.
> >
> >
> > >
> > > my "make dep" result :
> > >  ...
> > > In file included from ../include/pjmedia/config.h:26,
> > >                  from ../include/pjmedia/types.h:27,
> > >                  from ../include/pjmedia-codec/config.h:22,
> > >                  from ../include/pjmedia-codec/types.h:22,
> > >                   from ../include/pjmedia-codec/l16.h:22,
> > >                  from ../src/pjmedia-codec/l16.c:19:
> > > ../../pjlib/include/pj/config.h:1006:4: error: #error
> "PJ_HAS_HIGH_RES_TIMER
> > > is not defined!"
> > >  ../../pjlib/include/pj/config.h:1022:4: error: #error
> "PJ_EMULATE_RWMUTEX
> > > should be defined in compat/os_xx.h"
> > > ../../pjlib/include/pj/config.h:1026:4: error: #error
> > > "PJ_THREAD_SET_STACK_SIZE should be defined in compat/os_xx.h"
> > >  ../../pjlib/include/pj/config.h:1030:4: error: #error
> > > "PJ_THREAD_ALLOCATE_STACK should be defined in compat/os_xx.h"
> > > ...
> > >
> > > As the previous person has described in his post, after ./configure, all
> the
> > > macros are undefined in
> > >  pjlib/include/pj/compat/os_auto.h
> > >
> >
> > >From the config.log it looks like things were set properly, but for
> > some reason the settings are not written to os_auto.h. What is you
> > delete pjlib/include/pj/compat/os_auto.h, and re-run ./config.status?
> > Does the os_auto.h get written properly?
> >
> > Cheers
> >  Benny
> >
> >
> >
> >
> >
> >
> > > svn status result :
> > >
> > > [tflo at D820-15 Stack_PjSIP]$ svn status
> > > X      third_party/speex
> > > X      third_party/portaudio
> > > Performing status on external item at 'third_party/speex'
> > >  Performing status on external item at 'third_party/portaudio'
> > >
> > >
> > > finally, my "tail -100 config.log" result :
> > >
> > >
> > > [tflo at D820-15 Stack_PjSIP]$ tail -100 config.log
> > > infodir='${prefix}/info'
> > >  libcrypto_present='1'
> > > libdir='${exec_prefix}/lib'
> > > libexecdir='${exec_prefix}/libexec'
> > > libssl_present='1'
> > > localstatedir='${prefix}/var'
> > > mandir='${prefix}/man'
> > >  oldincludedir='/usr/include'
> > > openssl_h_present='1'
> > > prefix='/usr/local'
> > > program_transform_name='s,x,x,'
> > > sbindir='${exec_prefix}/sbin'
> > > sharedstatedir='${prefix}/com'
> > >  sysconfdir='${prefix}/etc'
> > > target='i686-pc-linux-gnu'
> > > target_alias=''
> > > target_cpu='i686'
> > > target_os='linux-gnu'
> > > target_vendor='pc'
> > >
> > > ## ----------- ##
> > > ## confdefs.h. ##
> > >  ## ----------- ##
> > >
> > > #define HAVE_INTTYPES_H 1
> > > #define HAVE_LIBM 1
> > > #define HAVE_LIBNSL 1
> > > #define HAVE_LIBPTHREAD 1
> > > #define HAVE_LIBRT 1
> > > #define HAVE_LIBUUID 1
> > > #define HAVE_MEMORY_H 1
> > > #define HAVE_STDINT_H 1
> > >  #define HAVE_STDLIB_H 1
> > > #define HAVE_STRINGS_H 1
> > > #define HAVE_STRING_H 1
> > > #define HAVE_SYS_STAT_H 1
> > > #define HAVE_SYS_TYPES_H 1
> > > #define HAVE_UNISTD_H 1
> > > #define PACKAGE_BUGREPORT ""
> > > #define PACKAGE_NAME "pjproject"
> > >  #define PACKAGE_STRING "pjproject 0.8"
> > > #define PACKAGE_TARNAME "pjproject"
> > > #define PACKAGE_VERSION "0.8"
> > > #define PJSIP_HAS_TLS_TRANSPORT 1
> > > #define PJ_ATOMIC_VALUE_TYPE long
> > > #define PJ_BLOCKING_CONNECT_ERROR_VAL EINPROGRESS
> > >  #define PJ_BLOCKING_ERROR_VAL EAGAIN
> > > #define PJ_EMULATE_RWMUTEX 0
> > > #define PJ_HAS_ARPA_INET_H 1
> > > #define PJ_HAS_ASSERT_H 1
> > > #define PJ_HAS_CTYPE_H 1
> > > #define PJ_HAS_ERRNO_H 1
> > > #define PJ_HAS_ERRNO_VAR 1
> > > #define PJ_HAS_FCNTL_H 1
> > >  #define PJ_HAS_FLOATING_POINT 1
> > > #define PJ_HAS_HIGH_RES_TIMER 1
> > > #define PJ_HAS_IFADDRS_H 1
> > > #define PJ_HAS_LINUX_SOCKET_H 1
> > > #define PJ_HAS_MALLOC 1
> > > #define PJ_HAS_MALLOC_H 1
> > > #define PJ_HAS_NETDB_H 1
> > > #define PJ_HAS_NETINET_IN_H 1
> > >  #define PJ_HAS_NETINET_IP_H 1
> > > #define PJ_HAS_NET_IF_H 1
> > > #define PJ_HAS_SEMAPHORE_H 1
> > > #define PJ_HAS_SETJMP_H 1
> > > #define PJ_HAS_SOCKLEN_T 1
> > > #define PJ_HAS_SO_ERROR 1
> > > #define PJ_HAS_STDARG_H 1
> > > #define PJ_HAS_STDDEF_H 1
> > >  #define PJ_HAS_STDINT_H 1
> > > #define PJ_HAS_STDIO_H 1
> > > #define PJ_HAS_STDLIB_H 1
> > > #define PJ_HAS_STRING_H 1
> > > #define PJ_HAS_SYS_IOCTL_H 1
> > > #define PJ_HAS_SYS_SELECT_H 1
> > > #define PJ_HAS_SYS_SOCKET_H 1
> > > #define PJ_HAS_SYS_TIMEB_H 1
> > >  #define PJ_HAS_SYS_TIME_H 1
> > > #define PJ_HAS_SYS_TYPES_H 1
> > > #define PJ_HAS_TIME_H 1
> > > #define PJ_HAS_UNISTD_H 1
> > > #define PJ_LINUX 1
> > > #define PJ_M_NAME "i686"
> > > #define PJ_NATIVE_STRING_IS_UNICODE 0
> > > #define PJ_OS_NAME "i686-pc-linux-gnu"
> > >  #define PJ_POOL_ALIGNMENT 4
> > > #define PJ_SELECT_NEEDS_NFDS 0
> > > #define PJ_SOCK_HAS_GETADDRINFO 1
> > > #define PJ_SOCK_HAS_INET_ATON 1
> > > #define PJ_SOCK_HAS_INET_NTOP 1
> > > #define PJ_SOCK_HAS_INET_PTON 1
> > > #define PJ_THREAD_ALLOCATE_STACK 0
> > >  #define PJ_THREAD_SET_STACK_SIZE 0
> > > #define STDC_HEADERS 1
> > > #endif
> > > #ifdef __cplusplus
> > > extern "C" void std::exit (int) throw (); using std::exit;
> > >
> > > aconfigure: exit 0
> > >
> > >
> > > Do you have any idea about this problem ?
> > >
> > > Thanks a lot, and best Regards,
> > >
> > > Electrocut
> > >
> > > _______________________________________________
> > >  Visit our blog: http://blog.pjsip.org
> > >
> > >  pjsip mailing list
> > >  pjsip at lists.pjsip.org
> > >  http://lists.pjsip.org/mailman/listinfo/pjsip_lists.pjsip.org
> > >
> > >
> >
> > _______________________________________________
> > Visit our blog: http://blog.pjsip.org
> >
> > pjsip mailing list
> > pjsip at lists.pjsip.org
> > http://lists.pjsip.org/mailman/listinfo/pjsip_lists.pjsip.org
> >
>
>
> _______________________________________________
>  Visit our blog: http://blog.pjsip.org
>
>  pjsip mailing list
>  pjsip at lists.pjsip.org
>  http://lists.pjsip.org/mailman/listinfo/pjsip_lists.pjsip.org
>
>




More information about the pjsip mailing list