[pjsip] Error in configuring SVN version, on Linux, i686

Benny Prijono bennylp at pjsip.org
Wed May 14 05:29:31 EDT 2008


On Wed, May 14, 2008 at 8:51 AM, Tanguy Floc'h <electrocut at gmail.com> wrote:
> > Can you show me the contents of undefs.sed?
>
> You're right, I found the tmp directory and the undefs.sed file inside. Here
> is it's content :
> http://docs.google.com/View?docID=dcmdgqxp_3cm5n7ggr&revision=_latest
>
> (it looks wrong too, right ?)
>

Actually at glance it looks okay (apart from lost of tabs because GDoc
strips them).

>
> >
> > And do you see a correct os_auto.h content when you run this?
> >
> >  sed -f confstat1244-27231/undefs.sed pjlib/include/pj/compat/os_auto.h.in
> >
>
>  the os_auto.h file is generated, but it still wrong. (I assume it is
> 'normal', since undefs.sed looks bad.
> You can have a look at the command line result here :
> http://docs.google.com/View?docID=dcmdgqxp_4dk66hwr2&revision=_latest
>

I tried to run your .sed file but sed complains about "sed: file
undefs.sed line 37: Unknown option to 's'". I suspect it's because
gdoc probably had messed up with the formatting of the file.

Here I attach my undefs.sed, also from CentOS 5 machine. What happen
if you run it (sed -f undefs.h path/to/os-auto.h.in)? I run it in both
CentOS 5 and Mingw machines and it produces os_auto.h fine.

Cheers
 Benny
-------------- next part --------------
A non-text attachment was scrubbed...
Name: undefs.sed
Type: application/octet-stream
Size: 3361 bytes
Desc: not available
URL: <http://lists.pjsip.org/pipermail/pjsip_lists.pjsip.org/attachments/20080514/6fa6e223/attachment.sed>


More information about the pjsip mailing list