[pjsip] Error in configuring SVN version, on Linux, i686

Benny Prijono bennylp at pjsip.org
Wed May 14 06:11:04 EDT 2008


On Wed, May 14, 2008 at 10:59 AM, Tanguy Floc'h <electrocut at gmail.com> wrote:
> > Actually at glance it looks okay (apart from lost of tabs because GDoc
> > strips them).
>
> I have attached my undefs.sed file, maybe it will be better without Gdoc
>
> > Here I attach my undefs.sed, also from CentOS 5 machine. What happen
> > if you run it (sed -f undefs.h path/to/os-auto.h.in)? I run it in both
> > CentOS 5 and Mingw machines and it produces os_auto.h fine.
>
> I'm afraid that for me it's still not good :(
>
> This is the result, when I run your sed file:
>
> [tflo at D820-15 Stack_PjSIP]$ sed -f undefs.sed
> pjlib/include/pj/compat/os_auto.h.in

[snip]

>
> /* Canonical OS name */
> /* #undef PJ_OS_NAME */
>

I run your undefs.sed and here I've got:

/* Canonical OS name */
#define PJ_OS_NAME "i686-pc-linux-gnu"

and the rest looks okay. So your undefs.sed is fine, but for some
reason your sed is unable to run your undefs.sed. Not sure why, but
here is the version that I have:

[root at sip support]# cat /etc/redhat-release
CentOS release 5 (Final)
[root at sip support]# rpm -qa | grep sed
sed-4.1.5-5.fc6
[root at sip support]#

Maybe you have different sed version? Or you're not running under bash?

Cheers
 Benny




More information about the pjsip mailing list