[pjsip] pasound.c PA message: Pa_GetDeviceInfo: Num input channels re, , ported as 65535! Changed to 2.

Nanang Izzuddin nanang at pjsip.org
Thu May 15 10:17:47 EDT 2008


Hi,

I don't think that is an error. This is PortAudio area actually, and
there is comment related to the message/case:
        /* For Windows versions using WDM (possibly Windows 98 ME and later)
         * the kernel mixer sits between the application and the
driver. As a result,
         * wave*GetDevCaps often kernel mixer channel counts, which
are unlimited.
         * When this happens we assume the device is stereo and set a flag
         * so that other channel counts can be tried with OpenStream
-- i.e. when
         * device*ChannelCountIsKnown is false, OpenStream will try whatever
         * channel count you supply.

However it seems the application is shutting down. Not sure why the
sound device/application is suddenly shutdown, it could be caused by
lack of resource (handles or memory). Does that always happen (even
after the system in fresh condition/just restarted)? Which application
is that?

Regards,
nanang


2008/5/15 Abdul Khadar <abdul.khadar at pyronetworks.com>:
> Hi,
>
> the error which I am getting .
>
> 15:13:37.781      pasound.c PA message: Pa_GetDeviceInfo: Num input channels
> reported as 65535! Changed to 2.
>
> 15:13:37.781      pasound.c PA message: Pa_GetDeviceInfo: Num input channels
> reported as 65535! Changed to 2.
>
> 15:13:37.781      pasound.c PA message: Pa_GetDeviceInfo: Num output
> channels reported as 65535! Changed to 2.
>
> 15:13:37.796      pasound.c PA message: Pa_GetDeviceInfo: Num output
> channels reported as 65535! Changed to 2.
>
>  15:13:37.875      pasound.c PortAudio sound library initialized, status=0
>
>  15:13:37.875      pasound.c PortAudio host api count=3
>
>  15:13:37.875      pasound.c Sound device count=12
>
>  15:13:37.875          pjlib WinNT IOCP I/O Queue created (14159E1C)
>
>  15:13:37.875      pasound.c PortAudio sound library shutting down..
>
> Above error , I am getting in windows XP SP2,  please suggest me , what will
> be the cause for this error.
>
> This error I am getting HP laptop only. It is working fine in personal PC
> windows XP sp2 and windows vistha also.
>
> please help me in this as soon as possible.
>
> thanks & regards,
>
> Abdul Khadar.
>
>
> _______________________________________________
> Visit our blog: http://blog.pjsip.org
>
> pjsip mailing list
> pjsip at lists.pjsip.org
> http://lists.pjsip.org/mailman/listinfo/pjsip_lists.pjsip.org
>
>




More information about the pjsip mailing list