[pjsip] cannot compile Symbian to get symbian_ua.exe to Emulator

Benny Prijono bennylp at pjsip.org
Tue May 20 04:56:05 EDT 2008


On Tue, May 20, 2008 at 3:06 AM, Rodrigo Vega <vegaroy13 at gmail.com> wrote:
> Hi Benny:
>
> I'm working over symbian.
>
> I was working over revition of SVN 1820, as long as I was getting one error
> in sip_config.h (I think) I updated from SVN to get rev. 1961( a few hours
> ago)
> Then I clean up the project, and also refresh (here some files were updated
> and aggregated).
>
> I've been doing some tracing, and I know that the symbian_ua.exe would be
> placed over this path C:\Symbian\9.1\S60_3rd_MR\Epoc32\release\winscw\udeb,
> And some libs are created there when I 'Build Target Only', and I got this
> error.
>
>
> Errors caused tool to abort.
> make[1]: ***
> [\Symbian\9.1\S60_3rd_MR\EPOC32\RELEASE\WINSCW\UDEB\pjlib_test.exe] Error 1
> make: *** [TARGETPJLIB_TEST] Error 2
>

Thanks for the report, I've just fixed this in r1962, it should build
fine now. But just FYI, you're building pjlib_test.exe rather than
symbian_ua.exe, I'm not sure if that's what you want.

> Please help me, I don't know what else to do.
> btw. I don have on-device debugging due to license expiration (is this the
> error???)
>

No, this is just my mistake. The licensing only affects device
debugging and you should still be able to build pjsip for the device
and run it there (without debugging it).

Thanks for the report.

Cheers
 Benny




More information about the pjsip mailing list