[pjsip] Conferencing Problem delaying voice

Nanang Izzuddin nanang at pjsip.org
Fri May 23 12:00:10 EDT 2008


Since it seems you are using OSS, please make sure you are using the
latest SVN trunk version which contains update on handling imprecise
audio frame size which may cause breaking voice (see ticket #523:
http://trac.pjsip.org/repos/ticket/523), and also contains update on
jitter buffer optimization to minimize delay caused by jittery network
(see ticket #505: http://trac.pjsip.org/repos/ticket/505).

Regards,
nanang


2008/5/23 Abdul Khadar <abdul.khadar at pyronetworks.com>:
> Hi,
>
> I have developed a shared library using pjsip.  By using this pjsip shared
> library I want to create conference with a java program. For a single call
> it is working fine , when I am placing more than one call and I am adding
> this port to the conference pool.
>
> After call is  entered into conference voice reaching to all persons who are
> in conference ,but voice is braking i.e. delay in voice.
>
> Below is the configuration for each port.
>
> Port #00:
>   Name                    : /dev/dsp
>   Sampling rate           : 16000 Hz
>   Samples per frame       : 160
>   Frame time              : 10 ms
>   Signal level adjustment : tx=0, rx=0
>   Current signal level    : tx=0, rx=0
>   Transmitting to ports   : #1 #2
>
> Port #01:
>   Name                    : strm0x530bf0
>   Sampling rate           : 16000 Hz
>   Samples per frame       : 160
>   Frame time              : 10 ms
>   Signal level adjustment : tx=0, rx=0
>   Current signal level    : tx=0, rx=0
>   Transmitting to ports   :  #0 #2
>
> Port #02:
>   Name                    : strm0x531128
>   Sampling rate           : 16000 Hz
>   Samples per frame       : 160
>   Frame time              : 10 ms
>   Signal level adjustment : tx=0, rx=0
>   Current signal level    : tx=0, rx=0
>   Transmitting to ports   :  #0 #1
>
> this configuration changed to 8000 hz, 240 sample 20 ms also, when I have
> this sample rates voice was more breaking, so I change to 10ms. It was
> little bit ok but still it is breaking.
>
> please  any one help me to solve this problem.
>
> thanks & regards,
> Abdul Khadar.
> _______________________________________________
> Visit our blog: http://blog.pjsip.org
>
> pjsip mailing list
> pjsip at lists.pjsip.org
> http://lists.pjsip.org/mailman/listinfo/pjsip_lists.pjsip.org
>
>




More information about the pjsip mailing list