[pjsip] crash with stereo option

Samuel Vinson samuelv at laposte.net
Fri May 23 17:42:13 EDT 2008


Hi Nanang,

Nanang Izzuddin a écrit :
 > Hi Samuel,
 >
 >
 > 2008/5/22 Samuel Vinson <samuelv at laposte.net>:
 >> Hi,
 >>
 >> I made several test with pjsua (on iphone) and clock-rate, stereo 
options.
 >>
 >>
 >> PJMEDIA_RESAMPLE_IMP == PJMEDIA_RESAMPLE_NONE
 >> PJMEDIA_RESAMPLE_IMP == PJMEDIA_RESAMPLE_LIBRESAMPLE
 >> --stereo     |   def  | undef
 >> --clock-rate |
 >>     8000     | ko (2) | ok (1)
 >>     16000    | ok (1) | ok (1)
 >>     22050    | ok (1) | ok (1)
 >>     44100    | ok (1) | ok (1)
 >>
 >> (1) but mediaserverd uses cpu at 80-95%
 >
 > Not sure what's going on here, since this happens regardless channel
 > number and clock rate used, it seems to be platform specific problem.

Yes, I agree with you, the problem comes from iPhone and not pjsip.

 >> (2) there are no sound that comes micro, mediaserverd uses cpu at 10%,
 >> but crash/reboot when you quit pjsua (start, quit => crash)
 >
 > While opening stereo in other clock rates seems to be fine, it is
 > still too dark, at least for me. I have simply tried to reproduce
 > (stereo on 8kHz) on my XP SP2 for both resample implementations you
 > mentioned above, but all of them seem to be fine in my machine.

Could you explain me, how pjsip works when stereo is active or not ?
I thought the media part is the same, and stereo option duplicates after 
  acquiring step.

 > If it is possible for you to generate log file or call stack trace of
 > debugger, it should help much.

I will try, for log file there are no problem, but for call stack trace 
I will look for.

Samuel

 >
 >
 > Regards,
 > nanang
 >
 > _______________________________________________
 > Visit our blog: http://blog.pjsip.org
 >
 > pjsip mailing list
 > pjsip at lists.pjsip.org
 > http://lists.pjsip.org/mailman/listinfo/pjsip_lists.pjsip.org
 >
 >




More information about the pjsip mailing list