[pjsip] Register failed in symbian using TLS transport

Klaus Darilion klaus.mailinglists at pernau.at
Wed Aug 5 08:00:12 EDT 2009


I would try to debug the problem why the transport was destroyed. Verify 
if TCP connection is established or not, if ServerHello and Cleint Hello 
are exchanged, or if the error happens inside the client without even 
sending any data

klaus

Vasyl Strutynskyy schrieb:
> Hi,
> 
> I have faced with the same problem, SSL_Connect() returns -1, did you 
> resolve this issue?
> 
> I have used console symbian app. Client logs below:
> 
>  22:46:30.941    pjsua_acc.c  Account sips:102 at morrigan.ua 
> <mailto:sips%3A102 at morrigan.ua> added with id 1
>  22:46:30.950   tlsc0x727fbc  TLS client transport created
>  22:46:30.989   tlsc0x727fbc  TLS transport destroyed with reason 
> 171168: Unknown error when performing SSL connect() (PJSIP_TLS_ECONNECT)
>  22:46:30.990    tsx0x726cac  Failed to send Request msg 
> REGISTER/cseq=33140 (tdta0x727258)! err=171168 (Unknown error when 
> performing SSL connect() (PJSIP_TLS_ECONNECT))
>  22:46:31.001    pjsua_acc.c  SIP registration failed, status=503 
> (Unknown error when performing SSL connect() (PJSIP_TLS_ECONNECT))
>  22:46:31.031      sip_reg.c  Error sending request, status=171168
>  22:46:31.031    pjsua_acc.c  Unable to create/send REGISTER: Unknown 
> error when performing SSL connect() (PJSIP_TLS_ECONNECT) [status=171168]
> 
> Thanks
> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> Visit our blog: http://blog.pjsip.org
> 
> pjsip mailing list
> pjsip at lists.pjsip.org
> http://lists.pjsip.org/mailman/listinfo/pjsip_lists.pjsip.org




More information about the pjsip mailing list