[pjsip] pjsua not responding correctly when hold is rejected

Benny Prijono bennylp at teluu.com
Thu Aug 20 19:03:15 EDT 2009


Hi Rafael,

I just tested this few days ago as part of 1.4 QA and hold scenarios
seem to work as expected (including double hold and stuff). But mind
you we will reply with "inactive" even though remote is sending
"sendonly", if the offer has 0.0.0.0 in the SDP "c" line. A well known
softphone does this in its hold request.

I can't speak for 1.0.1 behavior though, haven't used it for long time.

Cheers
 Benny

On Wed, Aug 12, 2009 at 8:42 PM, Rafael Maia<rmaia_lcm at hotmail.com> wrote:
> Hi,
>
> i am using pjsip 1.0.1.
>
>
> The following hold scenario is not working has expected:
>
> User A and User B are in call.
> Call is being relayed by an application server.
>
> 1º User A sends invite to hold call
> INVITE
> "sendonly"
>
>
> 2º Server (rejects hold operation)
> 603 declined
>
>
> 3º User B sends invite to hold call
> INVITE
> "sendonly"
>
>
> 4º User A receives invite and sends response
> 200 OK
> "inactive"
>
>
>
> On step 4, the response should be:
> 200 OK
> "recvonly"
> It seem that pjsua is responding as if the hold operation on step 1 had
> worked.
>
>
> Can anyone confirm this?
> If so, has this been fixed in the trunk?
>
> tks,
>
> Rafael Maia
> ________________________________
> Quer uma internet mais segura? Baixe agora o novo Internet Explorer 8. É
> grátis!
> _______________________________________________
> Visit our blog: http://blog.pjsip.org
>
> pjsip mailing list
> pjsip at lists.pjsip.org
> http://lists.pjsip.org/mailman/listinfo/pjsip_lists.pjsip.org
>
>




More information about the pjsip mailing list