[pjsip] Something very much annoying after INVITE request sent

Benny Prijono bennylp at teluu.com
Fri Aug 21 05:52:52 EDT 2009


Accodring to the spec, we cannot send CANCEL before receiving
provisional response from the UAS, so maybe that's what you're seeing.
The library delays sending CANCEL, but it will send it automatically
once provisional response is received.

If you want instant hangup appearance to the user, the GUI can
"pretend" that the call has been hung up to the user, though you still
need to handle the case where turns out UAS responds with 200/OK to
the initial INVITE (in this case just hangup the call again).

Cheers
 Benny

On Fri, Aug 21, 2009 at 10:40 AM, Hasan H<mailstohasan at gmail.com> wrote:
> Hello benny,
>
> Do you have any suggestion about this matter?
>
> On Thu, Aug 20, 2009 at 8:30 PM, Hasan H <mailstohasan at gmail.com> wrote:
>>
>> Hi all,
>>
>> Have anyone ever faced this kind of problem? specially for the handsets
>> which doesn't have WLAN rather only GPRS or 3G. In my case it was N73.
>>
>> After calling if i want to disconnect the call before getting "EARLY"/
>> 180   , it seems hang for sometimes. doesn't disconnect the call
>> immediately. As this is not happening all the time thats why it is very much
>> confusing.
>>
>> My question, is there any way to resolve this issue. Like force to hang-up
>> the call immediately ?
>>
>> Also, If i want to disconnect the call if i don't get the 100 (trying)
>> from server after sending "INVITE" in between 1/2 secs what i need to ?
>>
>> My tested application "was Symbian_ua_gui"
>>
>> Thanks,
>>
>>
>
>
> _______________________________________________
> Visit our blog: http://blog.pjsip.org
>
> pjsip mailing list
> pjsip at lists.pjsip.org
> http://lists.pjsip.org/mailman/listinfo/pjsip_lists.pjsip.org
>
>




More information about the pjsip mailing list