[pjsip] Something very much annoying after INVITE request sent

Hasan H mailstohasan at gmail.com
Fri Aug 21 08:50:53 EDT 2009


On Fri, Aug 21, 2009 at 4:52 PM, Benny Prijono <bennylp at teluu.com> wrote:

> Accodring to the spec, we cannot send CANCEL before receiving
> provisional response from the UAS, so maybe that's what you're seeing.
> The library delays sending CANCEL, but it will send it automatically
> once provisional response is received.


hmm, is there a way to do like this, if the first provisional response(100)
from the server delays more than 2/3 sec then the INVITE will automatically
disconnect.  (may be it will break the spec :(  ...  )

>
>
> If you want instant hangup appearance to the user, the GUI can
> "pretend" that the call has been hung up to the user, though you still
> need to handle the case where turns out UAS responds with 200/OK to
> the initial INVITE (in this case just hangup the call again).


its like a cheat ;) , me too was thinking about that. But once user
disconnect the call in this way, there is high probability to make the
immediate second call. What will be happened then?

Thanks for your kind reply

>
>
> Cheers
>  Benny
>
> On Fri, Aug 21, 2009 at 10:40 AM, Hasan H<mailstohasan at gmail.com> wrote:
> > Hello benny,
> >
> > Do you have any suggestion about this matter?
> >
> > On Thu, Aug 20, 2009 at 8:30 PM, Hasan H <mailstohasan at gmail.com> wrote:
> >>
> >> Hi all,
> >>
> >> Have anyone ever faced this kind of problem? specially for the handsets
> >> which doesn't have WLAN rather only GPRS or 3G. In my case it was N73.
> >>
> >> After calling if i want to disconnect the call before getting "EARLY"/
> >> 180   , it seems hang for sometimes. doesn't disconnect the call
> >> immediately. As this is not happening all the time thats why it is very
> much
> >> confusing.
> >>
> >> My question, is there any way to resolve this issue. Like force to
> hang-up
> >> the call immediately ?
> >>
> >> Also, If i want to disconnect the call if i don't get the 100 (trying)
> >> from server after sending "INVITE" in between 1/2 secs what i need to ?
> >>
> >> My tested application "was Symbian_ua_gui"
> >>
> >> Thanks,
> >>
> >>
> >
> >
> > _______________________________________________
> > Visit our blog: http://blog.pjsip.org
> >
> > pjsip mailing list
> > pjsip at lists.pjsip.org
> > http://lists.pjsip.org/mailman/listinfo/pjsip_lists.pjsip.org
> >
> >
>
> _______________________________________________
> Visit our blog: http://blog.pjsip.org
>
> pjsip mailing list
> pjsip at lists.pjsip.org
> http://lists.pjsip.org/mailman/listinfo/pjsip_lists.pjsip.org
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pjsip.org/pipermail/pjsip_lists.pjsip.org/attachments/20090821/cab0f08a/attachment.html>


More information about the pjsip mailing list