[pjsip] painfully slow loading of PCM at 44100/1/20ms‏

Arthur Elksnis archie1983 at hotmail.co.uk
Sun Aug 23 18:42:29 EDT 2009


Hi,
   Sorry if you receive this the second time-- I hadn't registered yet when I sent this email first time.

   I have an OpenSuse 11 system-- all latest updates. It is an Intel Atom motherboard and the the sound device is: ALC662 Analog : ALC662 Analog : playback 1 : capture 1 (contents of "/proc/asound/pcm"). When I start PJSUA (v.1.4)-- it seems to be working all fine but when I try to initiate a call (doesn't matter whether it's incoming or outgoing), it gives these two messages:

[quote]
20:06:29.072  pjsua_media.c  Opening sound device PCM at 16000/1/20ms
20:06:29.074  pjsua_media.c  Opening sound device PCM at 44100/1/20ms
[/quote]

and sits there for at least a minute before finally starts playing the incoming stream.  I've tried it with several other options like:

[quote]
--snd-clock-rate=8000 --snd-auto-close=0 --auto-answer=200
[/quote]

and: --dis-codec=PCM at 8000

but it's all the same except the first line is shows the frequency that I specify:

[quote]
20:06:29.072  pjsua_media.c  Opening sound device PCM at 8000/1/20ms
20:06:29.074  pjsua_media.c  Opening sound device PCM at 44100/1/20ms
[/quote]

It seems that it really doesn't like "PCM at 44100/1/20ms" and loads it extremely slow and anything else (e.g. PCM at 8000/1/20ms) can't be loaded at all.

I have a PJSUA version 1.3 running on another OpenSuse machine and that one works fine:

the only difference that I noticed is that when I finish the call, the old and working version prints out this:

[quote]
 22:38:08.206  pjsua_media.c  Media session for call 0 is destroyed
 22:38:08.206  pjsua_media.c  Closing sound device after idle for 0 seconds
 22:38:08.206  pjsua_media.c  Closing default sound playback device and default sound capture device
[/quote]

while the new, non-working version prints this:

[quote]
 22:41:41.912  pjsua_media.c  Media session for call 0 is destroyed
 22:41:41.912  pjsua_media.c  Closing sound device after idle for 0 seconds
 22:41:41.912  pjsua_media.c  Closing HDA Intel: ALC662 Analog (hw:0,0) sound playback device and HDA Intel: ALC662 Analog (hw:0,0) sound capture device
[/quote]

Thanks in advance,
Arthur
_________________________________________________________________
Windows Live Messenger: Thanks for 10 great years—enjoy free winks and emoticons.
http://clk.atdmt.com/UKM/go/157562755/direct/01/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pjsip.org/pipermail/pjsip_lists.pjsip.org/attachments/20090823/51f04a7a/attachment.html>


More information about the pjsip mailing list