[pjsip] Porting PJSIP to iPhone OS 3.0

Samuel Vinson samuelv at laposte.net
Sat Dec 5 03:58:49 EST 2009


Hello Jin Li,

pjsip work fine on iPhone OS 2.2 to 3.1.2.

Apple didn't change any API since iPhone OS 2.0. It added new API only 
for new features.
You can try Siphon from Cydia, or you could install the last RC version 
of Siphon : http://code.google.com/p/siphon/downloads/list

Regards

Samuel

Chee Jin Li a écrit :
> Hi all,
>
> I am a student who currently working on a project to write an SIP application for iPhone. I currently searching for suitable SIP API and I came across PJSIP which is currently used by SIP application on App Store.
>
> Due to my lack of knowledge I do not know the proper method to port PJSIP to iPhone OS, I also tried to follow the step from http://code.google.com/p/siphon/wiki/Compilation but it seem that it will have issue trying to port for iPhone OS 3.0. 
>
> Currently I running on Mac OS X 10.6.2, and with Xcode 3.2.1. Any guide or help or hint will be deeply appreciated. Thanks in advance.
>
> Jin Li Chee
>
>
>       
>
> _______________________________________________
> Visit our blog: http://blog.pjsip.org
>
> pjsip mailing list
> pjsip at lists.pjsip.org
> http://lists.pjsip.org/mailman/listinfo/pjsip_lists.pjsip.org
>
>
>   





More information about the pjsip mailing list