[pjsip] Port 5060 conflict

Leonid Segal voknetlab at gmail.com
Thu Aug 5 16:21:24 CDT 2010


Hi.
Your both program work on port number 5060.
You should configure PJSUA to use another port.
The Sip server can still work on the same port.

On Sun, Aug 1, 2010 at 9:29 PM, Shamun toha md <shamun.toha at gmail.com>wrote:

> Dear Sir,
>
> This is a new trouble ticket request.
>
> My goal is building a soft phone (no sip server etc etc) using
> PJSIP/PJLIB/PJSUA. In this test suite, i am running my own Asterisk testing
> server using 5060 port.
>
> - Build/compile PJSUA sample code from  (
> http://www.pjsip.org/pjsip/docs/html/page_pjsip_sample_simple_pjsuaua_c.htm
> )
> - While Asterisk running if i run this Simple PJSUA, i get this error
> 20:14:48.863            APP  Error creating transport: Address already in
> use [status=120098]
>
> Please have a look in the screen shot: http://i.imgur.com/RV9Fa.png
>
> - if i shutdown my Asterisk server, and re run the PJ C example code, it
> works.
>
>
> Question: Can you please kindly tell me from where  i should start my
> journey to make a SIPphone (not sip server) using PJSIP?
>
>
> Thank you
> Best regards
> Shamun
>
> N.B: Is there any #pjsip in irc.freenode.net somewhere?
>
> _______________________________________________
> Visit our blog: http://blog.pjsip.org
>
> pjsip mailing list
> pjsip at lists.pjsip.org
> http://lists.pjsip.org/mailman/listinfo/pjsip_lists.pjsip.org
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pjsip.org/pipermail/pjsip_lists.pjsip.org/attachments/20100806/5c908459/attachment-0001.html>


More information about the pjsip mailing list