[pjsip] Where does PJSIP Expect opencore-amr to be?

Dan Arrhenius dan at keystream.se
Thu Feb 2 15:14:04 EST 2012


Just to be clear. It should all be on the same line:

"CFLAGS=... ..onfigure-iphone"

My mail client split the line in two.

Regards,
Dan

On Thu, 2012-02-02 at 21:09 +0100, Dan Arrhenius wrote:
> Hi,
> 
> try to set CFLAGS and LDFLAGS when running the configure script, like
> this:
> 
> CFLAGS="-I<path_to_installed_opencore>/include"
> LDFLAGS="-L<path_to_installed_opencore>/lib" ./configure-iphone
> 
> Regards,
> Dan
> 
> On Thu, 2012-02-02 at 19:59 +0000, Spencer MacDonald wrote:
> > Hi,
> > 
> > 
> > I have built opencore-amr for iOS and it has installed the binary
> > in /usr/local/lib but it seems like PJSIP doesn't look there.
> > 
> > 
> > The following gets logged in the console:
> > 
> > 
> > checking for OpenCORE AMR-NB installations..
> > checking opencore-amrnb/interf_enc.h usability... no
> > checking opencore-amrnb/interf_enc.h presence... no
> > checking for opencore-amrnb/interf_enc.h... no
> > checking for Encoder_Interface_init in -lopencore-amrnb... no
> > 
> > At first I thought it was my PATH but even update that didn't fix it:
> > 
> > 
> > /usr/local/include:/usr/local/lib:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/X11/bin:/usr/local/git/bin
> > 
> > 
> > Any advice?
> > 
> > 
> > Spencer
> > 
> > 
> > _______________________________________________
> > Visit our blog: http://blog.pjsip.org
> > 
> > pjsip mailing list
> > pjsip at lists.pjsip.org
> > http://lists.pjsip.org/mailman/listinfo/pjsip_lists.pjsip.org
> 
> 
> 
> _______________________________________________
> Visit our blog: http://blog.pjsip.org
> 
> pjsip mailing list
> pjsip at lists.pjsip.org
> http://lists.pjsip.org/mailman/listinfo/pjsip_lists.pjsip.org





More information about the pjsip mailing list