[pjsip] pjsip 2.0 simple ua alsa error on OMAP 4 ubuntu

Guilherme Balena Versiani guibv at nymgo.com
Tue Jun 5 16:32:32 EDT 2012


Compile against ALSA device from pjmedia-auddev, PortAudio + PJSIP won't
work in VMware.

Regards,
Guilherme Balena Versiani.
Em 31/05/2012 12:44, "Xingshan He" <xingshan.he at gmail.com> escreveu:

> When starting up simple UA, I get the following error:
>
> Expression 'snd_pcm_hw_params_set_buffer_size_near( pcm, hwParams,
> &lowLatency )' failed in
> 'src/../../../portaudio/src/hostapi/alsa/pa_linux_alsa.c', line: 415
> 11:26:01.574       pa_dev.c  ..PortAudio sound library initialized,
> status=0
> 11:26:01.575       pa_dev.c  ..PortAudio host api count=2
> 11:26:01.576       pa_dev.c  ..Sound device count=9
> 11:26:01.576          pjlib  ..select() I/O Queue created (0x1e49bb4)
>
>
> System info:
>
>  $ uname -a
> Linux linaro-ubuntu-desktop 3.1.1-29-linaro-lt-omap
> #29~lt~ci~20120328002449+1332949706~4f7349b0-Ubuntu SMP PREEMPT  armv7l
> armv7l armv7l GNU/Linux
>
>
> This is ubuntu 12.03 (linaro build) on pandaboard.
>
> I'd appreciate any help you can provide with this problem.  Thanks a lot.
>
> _______________________________________________
> Visit our blog: http://blog.pjsip.org
>
> pjsip mailing list
> pjsip at lists.pjsip.org
> http://lists.pjsip.org/mailman/listinfo/pjsip_lists.pjsip.org
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pjsip.org/pipermail/pjsip_lists.pjsip.org/attachments/20120605/595a9dbc/attachment.html>


More information about the pjsip mailing list