[pjsip] Python - pjsip BUG in the core?

Shamun Toha Md shamun at companysocia.com
Mon Dec 2 06:16:57 EST 2013


When i read it shows -1, -2 and if i set 0,0 still no luck.

    # Start the library
    lib.start()

    # when no sound card found
    #lib.set_null_snd_dev()
    snd_dev = lib.get_snd_dev()
    print snd_dev
    lib.set_snd_dev(0,0)


(-1, -2)
Expression 'SetApproximateSampleRate( pcm, hwParams, sr )' failed in
'src/../../../portaudio/src/hostapi/alsa/pa_linux_alsa.c', line: 1294
Expression 'PaAlsaStreamComponent_InitialConfigure( &self->capture,
inParams, self->primeBuffers, hwParamsCapture, &realSr )' failed in
'src/../../../portaudio/src/hostapi/alsa/pa_linux_alsa.c', line: 1870
Expression 'PaAlsaStream_Configure( stream, inputParameters,
outputParameters, sampleRate, framesPerBuffer, &inputLatency,
&outputLatency, &hostBufferSizeMode )' failed in
'src/../../../portaudio/src/hostapi/alsa/pa_linux_alsa.c', line: 1994
Expression 'SetApproximateSampleRate( pcm, hwParams, sr )' failed in
'src/../../../portaudio/src/hostapi/alsa/pa_linux_alsa.c', line: 1294
Expression 'PaAlsaStreamComponent_InitialConfigure( &self->capture,
inParams, self->primeBuffers, hwParamsCapture, &realSr )' failed in
'src/../../../portaudio/src/hostapi/alsa/pa_linux_alsa.c', line: 1870
Expression 'PaAlsaStream_Configure( stream, inputParameters,
outputParameters, sampleRate, framesPerBuffer, &inputLatency,
&outputLatency, &hostBufferSizeMode )' failed in
'src/../../../portaudio/src/hostapi/alsa/pa_linux_alsa.c', line: 1994


On Mon, Dec 2, 2013 at 6:43 AM, Nishant Rodrigues <nishantjr at gmail.com>wrote:

> Make sure you're linking pjsip with libasound.
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pjsip.org/pipermail/pjsip_lists.pjsip.org/attachments/20131202/07ce4276/attachment-0001.html>


More information about the pjsip mailing list