[pjsip] Sound problem pjsua at raspberry pi

Bill Gardner billg at wavearts.com
Wed May 14 12:58:07 EDT 2014


Hi Herbert,

Try disabling AEC and see if the "cc 0 0" test works better. AEC may be 
consuming all the CPU?

Bill

On 5/14/2014 12:50 AM, Herbert Falter wrote:
> Hi,
>
> I have a Raspberry PI with Raspbian and a USB-Sound-Device.
>
> **** Liste der Hardware-Geräte (PLAYBACK) ****
> Karte 0: Device [USB PnP Sound Device], Gerät 0: USB Audio [USB Audio]
>   Sub-Geräte: 1/1
>   Sub-Gerät #0: subdevice #0
> Karte 1: ALSA [bcm2835 ALSA], Gerät 0: bcm2835 ALSA [bcm2835 ALSA]
>   Sub-Geräte: 8/8
>   Sub-Gerät #0: subdevice #0
>   Sub-Gerät #1: subdevice #1
>   Sub-Gerät #2: subdevice #2
>   Sub-Gerät #3: subdevice #3
>   Sub-Gerät #4: subdevice #4
>   Sub-Gerät #5: subdevice #5
>   Sub-Gerät #6: subdevice #6
>   Sub-Gerät #7: subdevice #7
>
> The USB-Sound Device works great (very good quality) with alsa:
>
> aplay /usr/share/scratch/Media/Sounds/Vocals/Singer2.wav
>
> and recording with:
>
> arecord -D plughw:0 --duration=10 -f cd -vv  test.wav
>
> I read the site: http://trac.pjsip.org/repos/wiki/sound-problems.
>
> The playback-sound at "cc 0 0" is very bad.
> Abort at:
>
> >>> cc 1 0
> 22:52:13.499    pjsua_aud.c  Conf connect: 1 --> 0
> 22:52:13.500    pjsua_aud.c  .Set sound device: capture=-1, playback=-2
> 22:52:13.502    pjsua_app.c  ..Turning sound device ON
> 22:52:13.504    pjsua_aud.c  ..Opening sound device PCM at 16000/1/20ms
> 22:52:13.558     ec0x2c7460  ...AEC created, clock_rate=16000, 
> channel=1, samples per frame=320, tail length=200 ms, latency=0 ms
> 22:52:13.561   conference.c  .Port 1 
> (/usr/share/scratch/Media/Sounds/Vocals/Singer2.wav) transmitting to 
> port 0 (default:CARD=Device)
> Success
> >>> pjsua: ../src/pjmedia/conference.c:1498: read_port: Assertion 
> `cport->rx_buf_count <= cport->rx_buf_cap' failed.
> Abgebrochen
>
> What can I do?
>
> My configuration is:
> sudo apt-get update
> sudo apt-get upgrade
> sudo apt-get install alsaplayer-alsa  libv4l-dev libx264-dev 
> libssl-dev libasound2-dev
> cd
> sudo wget http://www.pjsip.org/release/2.2/pjproject-2.2.tar.bz2
> sudo tar xvfj pjproject-2.2.tar.bz2
> cd pjproject-2.2/
> sudo ./configure --disable-video --disable-l16-codec 
> --disable-gsm-codec  --disable-g722-codec --disable-g7221-codec 
> --disable-ilbc-codec
> echo "PJSIP: use ALSA instead of Portaudio"
> sudo cat << PJ > pjlib/include/pj/config_site.h
> #define PJMEDIA_AUDIO_DEV_HAS_ALSA       1
> #define PJMEDIA_AUDIO_DEV_HAS_PORTAUDIO  0
> PJ
> sudo make dep && make
> sudo make install
>
> sudo cp 
> /home/pi/pjproject-2.2/pjsip-apps/bin/pjsua-armv6l-unknown-linux-gnueabihf 
> /usr/bin/pjsua
>
> Please help.
>
> bye
> herbert
>
>
> _______________________________________________
> Visit our blog: http://blog.pjsip.org
>
> pjsip mailing list
> pjsip at lists.pjsip.org
> http://lists.pjsip.org/mailman/listinfo/pjsip_lists.pjsip.org

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pjsip.org/pipermail/pjsip_lists.pjsip.org/attachments/20140514/715e0677/attachment-0002.html>


More information about the pjsip mailing list