[pjsip] OSX QTkit has ben deprecated

Vittorio Giovara vittorio.giovara at savoirfairelinux.com
Tue May 27 11:21:32 EDT 2014


On 2014-05-26 15:07, Eeri Kask wrote:
> On Sun, 25 May 2014 08:13:23 +0200, samuelv at laposte.net wrote:
>> We are waiting your patch ;-)
>> Thanks a lot for your contribution
>
> As probably more OSX versions support QTKit as there is support for
> AVFoundation (esp. older hardware), please do not change anything at the
> expense of QTKit in PJSIP, it works very well.  :-)

The problem is that usually Apple usually removes deprecated frameworks 
in future versions of the operating system, so moving to the 
AVFoundation functions is the only way to guarantee that Pjsip will 
still work on OS X.

Vittorio




More information about the pjsip mailing list