[pjsip] Errors compiling pjsip with ssl on windows

Mike Roberts mike at switch.co
Fri Oct 30 17:59:21 EDT 2015


When I add "#define PJ_HAS_SSL_SOCK 1" to config_site.h I start to get
errors like the following.

31>  Generating Code...
31>C:\Program Files
(x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Microsoft.CppBuild.targets(1193,5):
warning MSB8012:
TargetPath(C:\Users\mike\repos\pjproject-2.4.5\pjsip-apps\build\.\output\pjsua--Win32-vc8-Debug-Static\pjsua.exe)
does not match the Linker's OutputFile property value
(C:\Users\mike\repos\pjproject-2.4.5\pjsip-apps\bin\pjsua-i386-Win32-vc8-Debug-Static.exe).
This may cause your project to build incorrectly. To correct this, please
make sure that $(OutDir), $(TargetName) and $(TargetExt) property values
match the value specified in %(Link.OutputFile).
31>C:\Program Files
(x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Microsoft.CppBuild.targets(1195,5):
warning MSB8012: TargetName(pjsua) does not match the Linker's OutputFile
property value (pjsua-i386-Win32-vc8-Debug-Static). This may cause your
project to build incorrectly. To correct this, please make sure that
$(OutDir), $(TargetName) and $(TargetExt) property values match the value
specified in %(Link.OutputFile).
31>LINK : fatal error LNK1104: cannot open file
'C:\Users\mike\repos\pjproject-2.4.5\pjlib\lib\pjlib-i386-Win32-vc8-Debug-Static.lib'

If I don't have PJ_HAS_SSL_SOCK set then pjsip compiles just fine.

I'm on Microsoft Visual Studio Community 2013
v 12.0.31101.00 Update 4
windows 8 64 bit


Has anyone encountered this before? I'm a complete VS noob so I don't even
know where these settings are, let alone why adding a #define would break
the linker.

Thanks,
Mike R.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pjsip.org/pipermail/pjsip_lists.pjsip.org/attachments/20151030/b9415e8e/attachment-0002.html>


More information about the pjsip mailing list